TLZone Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
Hey guys hopefully u can help, 98.tl1000r. I turn key to on, display lights come on, headlights, etc... Don't hear injectors or any noises period. Fault light on. Kickstand up, in neutral and tried pulling in clutch. Still no dice, still says chec
 

·
Registered
1998 TLS; 2001 TLR; 200X TLRSF
Joined
·
4,313 Posts
Hey guys hopefully u can help, 98.tl1000r. I turn key to on, display lights come on, headlights, etc... Don't hear injectors or any noises period. Fault light on. Kickstand up, in neutral and tried pulling in clutch. Still no dice, still says chec
Since it displays "CHEC," that indicates the problem is with the Engine Stop Switch (aka Kill Switch) circuit or the Side Stand Relay circuit. Both of them cut power to the ECM, and until the power is restored the gauge cluster will display CHEC.

Flick the kill switch a few times to clear the contacts. Also could be a broken wire in the circuit. Sometimes wires get smashed near the headstock. Sometimes solder connections in the switch come loose.

Also bypass the side stand switch as a test. The SS switch is not a reliable design. At the very least use a meter to verify that it is switching. If it is, then move to the SS relay to make sure it is working and getting the signal from the SS switch.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #4
Thanx, this is my first tl, I know there's a fuse box up front where's the relay at?
 

·
Registered
Joined
·
69 Posts
Discussion Starter #5
I noticed also that on the led display its flashing the oil symbol, I checked the side and see very low oil, would low oil stop bike from starting
 

·
Registered
Joined
·
4,456 Posts
The oil light is on because the engine isn't running therefore the oil PRESSURE is low.
When you looked at the oil level,was it on the sidestand?
Oil level should be checked with warm engine and perfectly upright.(like on pair of stands that lift front and rear the same)

Alternatively you can do it at 70mph :lol



Aaah.I crack myself up sometimes.:laugh
 

·
Registered
Joined
·
69 Posts
Discussion Starter #7
Lol, love the pic. Yea it was level. I don't know where the relay is and no I don't here the pump, my friend who owns the same tom says that when u have no faults ie; in neutral, kill switch off, kickstand up, clutch in u should hear it, I've tried all those and still nothing. I've also had issues finding the correct battery, could wrong battery keep bike from allowing me to start it?
 

·
Registered
Joined
·
4,456 Posts
The sidestand relay is combined with the flasher relay (great idea huh?) It is up at the fuse box inside the RHS fairing.
The relay is usually ok,try chasing the sidestand switch wiring up to the connector near the battery.
Unplug the relay wiring and jump the connector.
 

·
Registered
Joined
·
4,456 Posts
 

·
Registered
Joined
·
200 Posts
In gear with side stand down?
 

·
Registered
Joined
·
69 Posts
Discussion Starter #12
Ok, so bypassed all the switches, got bike to longer throw fault. I hear fuel pump relay click but fuel pump won't prime. I did some searching and a guy in a thread said that to check pull fuel pump relay off, connect multimeter and check wires.

Orange black has constant 12v
Orange/white gets power after key is on
Yellow/blue wire is suppose to have power then drop for 3 sec. To trip relay to connect orange black to yellow/red . The problem is I'm not getting any power from yellow/ black to begin with. I checked that pin on ecm, still no power. Is ecm bad? Or any other reason why I wouldn't get power through the wire ?
 
1 - 12 of 12 Posts
Top