TLZone Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I was riding down the road & had to slow down for another car & throttled back up & the bike just shut off without warning the engine oil light came on & I couldn’t get it back started. It has just had an oil change. What would b the first thing I would need to check out the fuel pump is kicking on & it will try to start it just won’t fire over.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #2
I was riding down the road & had to slow down for another car & throttled back up & the bike just shut off without warning the engine oil light came on & I couldn’t get it back started. It has just had an oil change. What would b the first thing I would need to check out the fuel pump is kicking on & it will try to start it just won’t fire over.
Also it has oil in it & showed no signs of leaking
 

·
Registered
Joined
·
5,710 Posts
If you mean the red light came on when it stalled that's normal, it's an oil pressure light, if you get it started again the light will go out.
There is some other reason that it won't start.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
If you mean the red light came on when it stalled that's normal, it's an oil pressure light, if you get it started again the light will go out.
There is some other reason that it won't start.
That’s what I thought as well. The only other thing I can think of at this point is something electrical. the starter is rolling pretty hard and it shakes the whole bike or I’m thinking stator or rectifier
 

·
Registered
Joined
·
565 Posts
Also check your starter relay. It's the green thing just above the battery box. Look for ANY signs of burning or corrosion. Look at the wiring going to the rectifier for any of the same issues. Other things to are the large white and yellow connectors below the left ram air duct. See if any of the pins have any corrosion on them as well.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
Thanks I think I found what it was after I got it home the next morning I had a trailer with fuel all over it so I’m thinking it’s gonna b a fuel issue hopefully just a line
 

·
Registered
Joined
·
1 Posts
I was riding down the road & had to slow down for another car & throttled back up & the bike just shut off without warning the engine oil light came on & I couldn’t get it back started. It has just had an oil change. What would b the first thing I would need to check out the fuel pump is kicking on & it will try to start it just won’t fire over.
I was riding down the road & had to slow down for another car & throttled back up & the bike just shut off without warning the engine oil light came on & I couldn’t get it back started. It has just had an oil change. What would b the first thing I would need to check out the fuel pump is kicking on & it will try to start it just won’t fire over.
I just saw this post from days ago. Have you got it started yet? Is it in neutral when your trying to start it? Is it all stock or aftermarket parts?
 

·
Registered
Joined
·
106 Posts
I was riding down the road & had to slow down for another car & throttled back up & the bike just shut off without warning the engine oil light came on & I couldn’t get it back started. It has just had an oil change. What would b the first thing I would need to check out the fuel pump is kicking on & it will try to start it just won’t fire over.

Well i only ask this because ive done it myself its not the killswitch, kickstand or tip sensor is it? I think they throw a code but its happened to me already.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
I have not got it started yet & it’s driving me crazy not to b able to ride but it is what it is. It is in neutral. My speed sensor was just kinda dangling around so I put a new bolt in & it didn’t help or hurt. Haven’t had one sign of any more fuel leaking.
I just saw this post from days ago. Have you got it started yet? Is it in neutral when your trying to start it? Is it all stock or aftermarket parts?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #11
Well i only ask this because ive done it myself its not the killswitch, kickstand or tip sensor is it? I think they throw a code but its happened to me already.
QUOTE]
I believe your right but if it was those 3 it wouldn’t even try almost like not having power. It try’s to start it just won’t crank
 

·
Registered
Joined
·
106 Posts
QUOTE]
I believe your right but if it was those 3 it wouldn’t even try almost like not having power. It try’s to start it just won’t crank
Correct. Ill admit i didnt read thoroughly.
Maybe i should do that before i ask my next question but does it have spark?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #13
Correct. Ill admit i didnt read thoroughly.
Maybe i should do that before i ask my next question but does it have spark?
I haven’t got a chance to really dig that deep yet. I’m waiting for some nice weather to b able to really tear it apart but it has rained pretty much everyday since the problem started
 

·
Registered
Joined
·
106 Posts
I haven’t got a chance to really dig that deep yet. I’m waiting for some nice weather to b able to really tear it apart but it has rained pretty much everyday since the problem started
Oh i see one those fair weather guys huh? Hahaha!
One other thing when youre trying to start it smell the exhaust pipe to see if you smell gas. You should smell unburn fuel past that youll want to listen for compression almost like when you stick you finger in a jug and pop it out. If youre not hearing something similar youve got low or no compression.
I dunno mine literally blew up last week. I haven't had the heart to realky open it up but atva glance i can see thevrear cylinder is cracked... thatvalways a good sign.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #15
Oh i see one those fair weather guys huh? Hahaha!
One other thing when youre trying to start it smell the exhaust pipe to see if you smell gas. You should smell unburn fuel past that youll want to listen for compression almost like when you stick you finger in a jug and pop it out. If youre not hearing something similar youve got low or no compression.
I dunno mine literally blew up last week. I haven't had the heart to realky open it up but atva glance i can see thevrear cylinder is cracked... thatvalways a good sign.
My concern was getting moisture or water in the fuel system. I’ll ride in a thunderstorm just to get to ride. Haha
 

·
Registered
1998 TLS; 2001 TLR; 200X TLRSF
Joined
·
4,322 Posts
I was riding down the road & had to slow down for another car & throttled back up & the bike just shut off without warning the engine oil light came on & I couldn’t get it back started. ....... the fuel pump is kicking on & it will try to start it just won’t fire over.
Given the manner and abruptness in which your TLR stopped running, I would suspect a fuel delivery problem. You don't mention it, but if the external fuel filter mod has been done, it's possible that the fuel line inside the tank connected to the pump has dislodged. If that's the case, the fuel pump will run (which you confirmed), but it cannot create pressure in the fuel rail because the line is disconnected inside the tank.

Fuel delivery can easily be verified with the 'fuel volume test' on page 4-51 in the service manual.

The fact that the red LED illuminated (oil light as tlsgazza noted), and you were able to crank it over afterwards, says that the initial problem was most likely not electrical.

Thanks I think I found what it was after I got it home the next morning I had a trailer with fuel all over it so I’m thinking it’s gonna b a fuel issue hopefully just a line
.....
Haven’t had one sign of any more fuel leaking.
What was the source of the fuel leak? And what did you do to fix it?

Of course, there could be other problems. If the fuel system is actually delivering fuel to the injectors, you will need a new set of spark plugs, because the existing ones are likely fuel fouled now after the many attempted starts.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #17
I’m getting a new fuel pump & a new set of plugs for it Saturday so we’ll see how it goes
 

·
Registered
Joined
·
15 Posts
Discussion Starter #18
New fuel pump & plugs & it ran like a champ I found once I got it back home that I have a small fuel leak that I will fix in the coming days then I found that my left fork seal is busted so I have a new project
 
1 - 20 of 21 Posts
Top