TLZone Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
602 Posts
Discussion Starter · #1 ·
Hey guys, where can I get the best price on a new battery for my 99 TLR? I've been charging my current battery at least once a week ever since running it the whole way down a couple of months ago (one of the relays had gone bad, and I kept trying different things to get her started, effectively killing the battery):banghead .

The battery is good to start the bike for a day or two, but then it needs some help (either jump starting off a car battery, or letting it trickle charge over night ) Everything runs great once the bike is up and running (so I'm assuming the stator is working just fine) I think the battery is just on it's way out. I

I'm not looking for a "Performance" battery, the factory weight is fine. Please drop me some Links if you know somewhere I can get one for a good price. I live in Northern Virginia (USA) if anyone knows of a local shop I can pick one up at for a good price. Thanks again :banana
 

·
Registered
Joined
·
75 Posts
not to hijack your thread but I had the same question... dealer cost is high...
went to pep boys, autozone, and wal-mart much better prices but no battery listed for TLR (YT12A-BS) only for the TLS (YTX12-BS). The TLS and GSXR1000 use the same battery. So, does anyone know if the battery for the TLS will work/fit in the TLR battery box? Or do I need to suck it up and go to the stealer? Also, any other battery suggestions would be greatly appreciated... :)
 

·
Registered
Joined
·
269 Posts
you may want check your regulator/rectifier/stator. or your starter relay. Mine killed the battery all the time if it sat for more than a few days couldnt figure out what was causing the problem until it finally brokea month later got a new one and all is well......do you have a hot starting problem? ohhh yeah yuasa is the only way to go
 

·
Registered
Joined
·
8,965 Posts
I bought mine from the local dealer, wasn't too bad.:O
 

·
Registered
Joined
·
602 Posts
Discussion Starter · #5 ·
I'll have to see how the bike behaves today. In the past, the only times I had trouble starting it up is when it had been sitting for a day or more. I put the trickle charger on it the other afternoon, and unplugged it before going to bed, nd in the morning it started up just fine. I rode to work, it sat all day, and it started alright when I came out from work at the end of the day. It was a BIT slower to start in the afternoon that it was in the morning, but it turned over after 3 or 4 cranks.
tunnelvision said:
you may want check your regulator/rectifier/stator. or your starter relay. Mine killed the battery all the time if it sat for more than a few days couldnt figure out what was causing the problem until it finally brokea month later got a new one and all is well......do you have a hot starting problem? ohhh yeah yuasa is the only way to go
 

·
Registered
Joined
·
871 Posts
if you have a walmart i got a m.f. for about 65.00 or 70.00 w/a lifetime warranty! it was an everstart and i haven't had any problems as of yet!:) :O
 

·
Registered
Joined
·
871 Posts
if you have a walmart i got a m.f. for about 65.00 or 70.00 w/a lifetime warranty! it was an everstart and i haven't had any problems as of yet! :) :O
 

·
Registered
Joined
·
2,650 Posts
ninforus said:
if you have a walmart i got a m.f. for about 65.00 or 70.00 w/a lifetime warranty! it was an everstart and i haven't had any problems as of yet! :) :O
It will last about 4 years & it will go belly up on you. I have a neverstart sitting on my workbench that belongs to a friend of mine with a 97' TLS. It died on him so I let him borrow the one out of my TLS last week. I didn't see that brand has a lifetime warranty? His battery held a charge pretty well after I stuck it on my trickle charger for 2 days. It charged up to 13.4 volts but dropped to 12.6 in 4 days sitting on my workbench. I ended up wanting to take my TLS out for a spin & tossed that battery in my TLS & rode it out to a local bike night. No problems at all until I shut it off outside my buddy's house down the street. We were talking about the weird ride home & the ignition was turned off on my TLS. When I turned it back on it was so dead it didn't even turn over. Just a faint click & the headlights dimmed when I hit the start button. That battery is gone. I highly recommend hard wiring a Battery Tender for these bikes...
 
1 - 9 of 9 Posts
Top