TLZone Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
new battery, new injectors, new throttle body new relay, traced all the wires, replace clutch switch bike turns over strong but won't start oh an kickstand switch is good what the hell else can it be
 

·
Registered
Joined
·
36 Posts
Hi I had this issue recently.
No doubt you’re aware, but you’re looking either at spark or a fuel issue, I worked through the below checklist first and tried each one.

Do you have any codes come up when the bike?

Does the fuel pump prime when you switch on the key?

Have you tried squirting a small amount of fuel in the TB’s and trying to start?

Have you checked for a spark on the plugs by grounding them out?
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #3 ·
the pump primes have not tried to ground the plugs yet an it started this today when I went out to try to Start it
 

·
Registered
Joined
·
5,740 Posts
It seems obvious, but, have you charged your battery or tried another one. Sounds like there's not enough power to start the bike.
 

·
Registered
Joined
·
5,740 Posts
I know you said you've fitted a new battery but they can be duff very quickly sometimes.
 

·
Registered
Joined
·
592 Posts
Check your starter relay. You need to look for any signs of corrosion or burnt wiring/terminals. If you need to replace it, buy only an OEM relay. The aftermarkets ones are iffy, at best.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #9 ·
ok get a battery a good one did all the stuff you guys told me an the bike turns on the fuel pump primes got a new relay an all I get is a click from the relay
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #11 ·
ok now it's turning over strong an the pump is priming strong but it's like I'm getting no fuel I tried to start it with the throttle open an I don't see any fuel when it primes
 
1 - 12 of 12 Posts
Top