TLZone Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I was riding down the interstate the other day and my bike just shut off for no aparent reason. Nothing would work/ guages, neutral light, fuel pump etc. So after checking all fuses I started jiggling wires and I found that one under the seat was coming loose. Its the one between the 2 fuses right behind the tank under the seat. The housing is cracked inside the plug. I looked at the microfiche on bikebandit.com and can't figure out where to find the plug, or if I have to get the whole wiring harness. Thanks in advance, Tim
 

·
Premium Member
Joined
·
7,287 Posts

·
Registered
Joined
·
2,799 Posts
some have eliminated the plug and just solidered those connections...you could always solider the connections and just get an aftermarket four wire moldex plug and wire it in at a later time....as for the plug... hard to find without buying another harness...good luck...
 

·
Registered
Joined
·
1,380 Posts
Ahhhh i had that same problem a couple of months ago. Like others have said you can solder the wires on but i just completely pulled the plug apart and cleaned everything and pinched the clips so they were connected tighter.
I had to cut the main power wire back abit to as the wire was slightly broken at the end. i just soldered a new section on.
Touch wood i havnt had a problem with it since.
 

·
Registered
Joined
·
1,076 Posts
saturating and cleaning the starter relay with actual electronic relay cleaner fixed mine right up and haven't had an issue in over a year of daily riding.

Try cleaining it up before doing the hard stuff like soldering or expensive stuff like replacing. Look over this board and you'll see lots of folks that have had the same issue.

good luck and happy new year,
C
 

·
Registered
Joined
·
1,171 Posts
I had a similar problem with mine which I eventually traced to the Datatag immobiliser, when I opened the case up it had a white powder in it which looked abit like talcum powder and it was causing the immobiliser to make the bike cut out whille I was riding. After cleaning it out I've had no probs . . not much use to you tho unless you also have an immobiliser fitted.
 

·
Registered
Joined
·
200 Posts
Ignition switch on mine....
 
1 - 9 of 9 Posts
Top