TLZone Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
anybody in the northeast or northwest ohio region wanna help diagnose my bike really need some help need to get it fixed motor noise of some sort please help me dont know anything about these bikes just got it
 

·
Moderator,
Joined
·
5,038 Posts
Shoot your problem on here bud, plenty of folk are bound to have had the same problem, it could be something simple that will get you going again :thumbup
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
i know i just need some help on where to start i dont have a service manual or any knowledge on this motor some has told me i spun a rod but to me it doesnt sound like it where should i start its a knocking noise at start up it came and went at first but now its there all the time then as i rev the motor it gets faster but it doesnt seem like crank speed or cam speed and under a load it starts to chirp and it feels like it has no power but it will move but it stalls real easy and battery dies very easily almosty like its not charging same noise whether the clutch is in or not while in neutral ive takin the valve covers off and started it and it definitely sounds like the front part of the motor i tightened the exhaust drained the opil it was ok screened it and everything nothing abnormal just dark oil plug had tiny bit of stuff on it nothing serious
 

·
Premium Member
Joined
·
24,892 Posts
Service manuals available in the file vault here, on chucksnet's page and on Jiffypark's website.
 

·
Premium Member
Joined
·
7,697 Posts
Man, it does sound like a rod big-end. Sorry.
 
1 - 7 of 7 Posts
Top