TLZone Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
Hi everybody!
I just got new TLS w 30k miles and it sat in storage w gas in the gas tank for 3 year, yeap....
and fuel pump is shot, so i cleanead up every bit of it and got new fuel pump motor , not whole unit, from Quantum fuels of Ebay, but when i was cleaning it all those rubber spacers broken up in pieces, i try to order those rubber pieces but cant find anyone who sell them.
Is there a way just strap it with ss hose clamps to the unit? Any advice on that? Im worried about vibrations...
 

Attachments

·
Premium Member
Joined
·
6,844 Posts
Please complete your profile to let us know where in the world you are - there maybe someone local who can offer help.

Regarding the rubbers, clean them up as well as you can and place them all in position then use a single strand of copper electrical supply cable ( solid core, say 1.5mm ) to wrap around near the base to hold them all in place.

Make it tight enough to hold that's all. Be aware there is not much room between the sides and the petrol pump seal gasket and you do not want to compromise that.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #3
Hi Ted, thanks for your advice i will try that.
As i researched some guys also use fuel pumps for cars, honda civic, suzuki swift...etc
But i would rather stick with bike parts��
Anyway, when i registered in TL forum i used my cellphone and the web page is water down computer version, so i changed the setting and i can actually add more info to my profile��
 
1 - 3 of 3 Posts
Top