TLZone Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,092 Posts
Discussion Starter #1
hey guys/gals, well the problems persist with my TLR, man i love this machine but it is giving me a headache.....today i changed out my generator cover o-ring, sealed up nicely, tried to change crush washer on drain plug but passed after loss of too much oil, so after i lost about 1/4 qt of oil i went to put some more back in and when i removed the clutch oil fill cap i looked at the bottom of it and it was covered in white slime/gunk/spooge. WTF, i searched on here and i came up with 2 threads. i gave it a whiff and i couldnt smell any coolant:O but i hvae been a little low on coolant latley i think, any other ideas what it could be, i took her out for a little run today, a balmy 28 degrees out came back parked it about 2 hours, checked it again and its covered in the white crap again. any ideas ya'll
thanks
ryan:banghead :banghead
 

·
Registered
Joined
·
790 Posts
If it's not coolant, I suspect it's just condensate. :O
 

·
Registered
Joined
·
1,092 Posts
Discussion Starter #3
yeah i took it out for about 7-10 mins, short trip. then went to garage and parked it.
 

·
Premium Member
Joined
·
24,892 Posts
Probably just condensation. How's the oil look? If its coolant the oil will look like a milkshake.
 

·
Registered
Joined
·
1,092 Posts
Discussion Starter #5
oil is fine, just changed it the other day and when i went to change out the crush washer i had quite a bit come out it was still nice and fresh........
 

·
Registered
Joined
·
3,289 Posts
If it's not coolant, I suspect it's just condensate. :O
:stupid Give it a good run, short runs especialy when cold outside will cause this.:thumbup
 

·
Registered
Joined
·
1,092 Posts
Discussion Starter #7
ahhhh thanks guys, you are always there to calm my nerves, yeah its cold as sh!t and i wasnt out that long so ill just take a few deep breaths and relax
 

·
Premium Member
Joined
·
4,013 Posts
Totally normal man, don't sweat it.
 
1 - 8 of 8 Posts
Top