TLZone Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
13,113 Posts
plug the inlet to the pump where the sock attaches and soak it in CLR

if the pump still runs it will be fine.
 

·
Registered
Joined
·
13,113 Posts
and the outlet too of course
 

·
Registered
Joined
·
5,677 Posts
Your TL must run on saline :lol
 

·
Registered
Joined
·
3,463 Posts
Ring-in; when you said "soak it in CLR" did you actually mean "soak it in cola"? :laugh
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter #8
Surprisingly the crap brushed off easily in about 4 mins .

The pump was blocked so I removed the end and blew some air through it then some wd40 .
To my surprise it started working
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter #9
In side the tank looked just as bad , so I threw in a handful of bolts and small amount of rust kill .
After shaking the tank for 5 mins I removed the bolts with a "magnet on a stick " and flushed . A LOT better .
Then plugged up the gas opening ,added 500m of Hydrocloric Acid (pool supplies ,very cheap ), plugged the pump opening (rag) and swilled it around for 1 min . Drain and flush . Don't breath the fumes its powerful. Be warned .
Result ,one 'AS new " , tank .


The bike had sat for 3 year and smelt terrible . The fuel looked like varnish with handfuls of scale in it .
 

·
Registered
Joined
·
293 Posts
I'd say you win a clean gas tank! Good work.
 

·
Premium Member
Joined
·
1,766 Posts
I hope you took lots of images of the procedure. I would like to remove mine eventually, and swap out the fuel filter.


Hydrochloric Acid :confused I always used Vinegar
 

·
Registered
Joined
·
3,463 Posts
Vinegar is for sissies. Anything that doesn't actually burn holes in things doesn't count as proper acid. :rotfl
 
1 - 12 of 12 Posts
Top