TLZone Forums banner

misfire

  1. Suzuki TL1000R & TL1000S Forum
    Hi guys, my tlr has been running abit odd recently...seems to be misfiring or cutting out for a split second while riding just enough to shift my weight forward slightly which isnt good during cornering. Doesnt happen all the time by mostly under acceleration......on the odd occasion the f1...
  2. Suzuki TL1000R & TL1000S Forum
    hey guys I have looked on the site for any answers but no 1 seems to have the answer?? now here's the fault I was goin ti pick the misses up the other day it fired up fine warmed up then got my gear on and she cut out I though she was being a cold ass so tried again no luck she never started and...
  3. Help Forum
    G'day Been checking out your site for a little while now, but this is my first post (don't get that much time to bum on the net. I know, priorities...). Some really nice TLs on here, you guys do well. Mine however is piece of s##t. It aint running right. Since I bought it Its always struggled...
  4. Help Forum
    Hi, Just wondering if anyone can suggest a fix for misfire on hot days (ambient over 30 degrees c)rode bike1000km in two days in rain,ran like a champ.return trip 1000km on last day 30km from home hot day stopped at road repairs took off and large misfire(no cylinders at all) shutting off and...
  5. UK Forum (Including Scotland)
    Morning all, I'm posting this here as opposed to the Tech or Raptor sections as I'm intrigued as to whether this is a common problem with TLSs, particularly UK models. My Raptor has been suffering with running a bit ropey below 3k which then turns into a proper misfire at 3k, which is great...
Top