TLZone Forums banner

help!

  1. Suzuki TL1000R & TL1000S Forum
    I just bought my first TLR the guy I bought it from had it sitting for over a year BC his battery's kept dying on him he said he would get it to run with a fresh battery and new spark plugs any idea on what you think the problem is? It turns on, primes, and clicks just can't get it to turn...
  2. Help Forum
    Hey guys, New to the forum and new to TL ownership. Picked up my 2001 TLS last week and it is without a rear seat. Finding it hard to locate one so far. Are there any other bikes whose rear seat is a perfect match fit wise? Thanks Tait
  3. Suzuki TL1000R & TL1000S Forum
    Hey there TLZONE ! I'm pretty new to this so I hope I've posted this in the right place . I've just bought my first 1998 TL1000R . It was in abit of a state so I've stripped all the fairings off and started to give it clean / adjust . I know of a few problems I have like the clutch is slipping...
  4. Help Forum
    Hello fellow members of tlzone. I just recently purchased a TLR from my friend who was in a bind. First i would like to say i love the sound and feel of the big Vtwin and it seems a little more comfy than my 09cbr600rr (totaled) but i could be wrong. What brings me to start this new thread is...
  5. Aussie Forum
    Hi guys i need a top right hand fairing for my tl1000s it seems there getting hard to find. while im here begging i may as well ask if theres any foot brake pedals out there or the rod that connects the gear shifter the the spline shaft (myn has bent), also i need a basic clutch whats my best...
  6. Help Forum
    Hi everybody, I am new TLZone has I just got a TLS. It was cheap but I need a few parts. The radiator is in bad shape, can we swap the tls radiator with any other suzuki parts? I think I might also have a problem with the damper unit, I don't think the unit should be moving at all? can anyone...
  7. Help Forum
    Hi there! Just thought I'd get my 2000 TLR out as it is the first nice day we've had in a while, but the git will not start. It was running fine before it was garaged about 2 weeks ago. When I turn the ignition on the fuel pump does not prime, and I am getting the message "chec" on the LCD...
  8. Open Forum
    Hey guys, I've got an 05 636 (ZX6R) and am a member of the sister forum Ninja6zone. See I want more torque on tap no matter what gear im in. Sure I could down shift, but everyone wants something different out of their bike and thats what I want out of mine but without going to a 1000cc inline...
  9. Suzuki TL1000R & TL1000S Forum
    Hey folks, I might just be a bit over careful etc but i've left my TL1000RW on tickover for about 5 minutes and noticed the Nearside exhaust isnt giving off any heat, I feel the exhaust pipe and its warmish but the off side is warmer, am i being a bit stupid or is this normal?:dowhat Also, it...
  10. Suzuki TL1000R & TL1000S Forum
    Well after 45k on my TLR, my upper radiator has taken its share of rock hits. It heats up quick and takes a while to cool off once moving again. I'm wondering if I can take a little flathead and gently pry the cooling fins back to allow air to pass through it once again? Anyone ever done...
  11. Suzuki TL1000R & TL1000S Forum
    My bike started bogging down on the highway today, then stalled. When I started it again it idled really roughly, and when I gave it any throttle it wouldn't pick up, just start popping and crackling unevenly, basically unrideable. Has anyone had a similar experience? Last night the F1 light lit...
  12. Suzuki TL1000R & TL1000S Forum
    I just got my first TLR and am very confused. Someone has done a mod to the air box with a UNI Foam filter and what looks to be velosity stacks. The bike is sluggish and does have M4 Full system. That is all that is done that I know of. The bike runs very hot 184 on freeway but 200-215 sitting...
  13. Help Forum
    :banghead I purchased a 01 TL1000R about 6 months ago and about two days ago it bomb out after joy riding for about 2 hours. The bike just shut off on the highway. When trying to restart the bike I didn't hear the fuel pump. The fuel light was on and the red light on the tachometer. Also I did...
  14. Suzuki TL1000R & TL1000S Forum
    to all you electronic wizards on the zone please help me with a simple led circuit well at least i think it should be ive got on the front of my nokia n96 a buttom with an led light behind it that makes it look like it is breathing ie it starts off dimm to full light then back again then off...
  15. Suzuki TL1000R & TL1000S Forum
    Need quick help. Trying to get the nut off the front sprocket. I've tried 2 impacts and a 6' cheater bar on there and nothing is working. Any suggestions??
  16. Suzuki TL1000R & TL1000S Forum
    Hey everyone, a good friend of mine up here in WA races a TLR. We were chatting last night, he said he got big gains with some aftermarket ram air tubes. Said he got 'em from a guy in the forums a couple years ago, thinks his screen name was something.....Nguyen.......Anyone know him or have...
  17. Suzuki TL1000R & TL1000S Forum
    Hey all, Glad to have joined such a great forum! Just picked up an '01 Tiller from a friend who has not started the bike in over a year. Attempted to start, no go. Picked up a new battery and installed it today. Cleaned some rust near fuel door, then siphoned the remaining gas a few times...
  18. Motor Tear Down and Rebuild
    Here's the story: Bike = '97TLS Charged the battery the night before (doesn't hold a charge too well...I know "get a new battery") Anyways.... the bikes running great and usually does. Doing about 70mph on the freeway when all of a sudden......... nothing. I mean nothing. The whole electrical...
  19. Suzuki TL1000R & TL1000S Forum
    I just bought lockhart phillips frame sliders with the off set for my tlr. I got them on kneedragers and they said they are specifically for my bike but it came with no direction or picture can any one help me?
  20. Suzuki TL1000R & TL1000S Forum
    i got tired of polishing my rims by hand so i went out and bought the mothers power ball attachment for my drill. it doesnt seem to do anything. what am i doing wrong. i am using the same polish i used when i did it by hand(which made it look awesome) appling it to the metal with a terry cloth...
Top