TLZone Forums banner
help:
1-6 of 6 Results
  1. MotardZone
    RXV 4.5 APRILIA from factory there oil tank sight level tube gives a false reading. i think it should be a recall fix myself. these pics are the mod to be done to correct the problem. 14MM x 1.50 banjo fitting a guy in USA used a auto power steering fitting ? i could not find one with the...
  2. Suzuki TL1000R & TL1000S Forum
    Now that it's all taken apart, I'd like to re-assemble my fork cartridge compression valves with the Gold Valves. Unfortunately, it seems I used my access code to get the Race Tech tuning data sheet years ago, and now it won't let me access it again when I really need it! I'm sure they will...
  3. Suzuki TL1000R & TL1000S Forum
    Hi everyone, first time on the site..... Just bought an '02 TLR the other day. Great bike. Only problem is, is that the previous owner installed a 'Mototeck' undertail kit with the twin pod brake lamps. They suck so bad, that you can hardly tell the difference in lamp brilliance when the rider...
  4. Suzuki TL1000R & TL1000S Forum
    Can anybody help?? I have just replaced battery on my TL1000R, and while fitting, alarm went off.Connected new battery terminals disarmed alarm with fob and carried on.Went to start, immobiliser works but alarm doesn't.No 'bleep' noises or indicator flashing only immobiliser works from fob...
  5. Open Forum
    i'm new to gps's so know nothing about loading maps. so i need some help / guidance please. i purchased a city map & tracks to upload to my garmin RHINO 520 the map has been custom made to suit my garmins memory size. the map is on a SD card which i have a sd/usb reader. i've loaded the map on...
  6. Suzuki TL1000R & TL1000S Forum
    Hi all Just a quick query to see if anyone has some ideas that i can attempt to troubleshoot what I've recently noticed. I took the bike for a brief ride Saturday afternoon, parked it up later at home and left it overnight. Went to wash it Sunday afternoon and noticed a fine layer of oil on the...
1-6 of 6 Results
Top