Brake calipers and discs
Page 1 of 4 1234 LastLast
Results 1 to 10 of 32

Thread: Brake calipers and discs

  1. #1
    Baby Twin
    Join Date
    Mar 2012
    Location
    stockport, cheshire
    Posts
    26

    Brake calipers and discs

    Hi All , it’s been a long time since I used this site, I’ve had problems with my brakes , long story short , they failed on me when I was taking my bike for new tyres, bought new pistons and seals for calipers and front master cylinder rebuild
    , well over due , having trouble getting pressure back on brake lever! On another note when calipers back on bike without dust cover I can see the brake discs aren’t central to caliper , this is causing one or if pistons to push out further than it should and other side is jammed against pad and brake disc ! All went back as it should but I can’t figure out what is wrong !! I will try and load some pictures later if I can ! I am presuming they should be central ! any advice welcome

  2. #2
    WSB Pit boss tlsgazza's Avatar
    Join Date
    May 2004
    Location
    wellingborough, northants, UK
    Posts
    5,604
    You've got the fork l GS in the correct place on the spindle when you tightened up the pinch bolts I take it.
    black TL1000S rider,owned from new since august 98,hinkle windowed clutch cover,braided lines,5/8 front brake M/cylinder.1/5 throttle,Helibars,double bubble,stainless renegade cans, ohlins damper,stainless rad and oil cooler covers,undertray,carbon hugger,silver powdercoated wheels,k+n filter and TRE,R+G bungs,LED indicators,gold X ring chain with 40T rear sprocket,mini indicators, HID H4 headlights with led side lights.now done 85,000 miles.
    gold busa forks,gold six pots and gold rear caliper,pazzo levers all thanks to speedking
    van driver clutch pressure plate and bolt retainers,
    also done 306 laps of the nurburgring,
    now have my r1200gs adventure with 95.000 miles covered to date.

  3. #3
    WSB Pit boss tlsgazza's Avatar
    Join Date
    May 2004
    Location
    wellingborough, northants, UK
    Posts
    5,604
    Quote Originally Posted by tlsgazza View Post
    You've got the fork l GS in the correct place on the spindle when you tightened up the pinch bolts I take it.
    Fat fingers. "Forks in the correct place on the spindle"
    black TL1000S rider,owned from new since august 98,hinkle windowed clutch cover,braided lines,5/8 front brake M/cylinder.1/5 throttle,Helibars,double bubble,stainless renegade cans, ohlins damper,stainless rad and oil cooler covers,undertray,carbon hugger,silver powdercoated wheels,k+n filter and TRE,R+G bungs,LED indicators,gold X ring chain with 40T rear sprocket,mini indicators, HID H4 headlights with led side lights.now done 85,000 miles.
    gold busa forks,gold six pots and gold rear caliper,pazzo levers all thanks to speedking
    van driver clutch pressure plate and bolt retainers,
    also done 306 laps of the nurburgring,
    now have my r1200gs adventure with 95.000 miles covered to date.

  4. Remove Advertisements
    TLZone.net
    Advertisements
     

  5. #4
    Baby Twin
    Join Date
    Mar 2012
    Location
    stockport, cheshire
    Posts
    26
    Sorry for late reply, been away, pretty sure everything is in the correct place , front disc and wheel are still of so will re assemble tomorrow and double check everything. Will update when done and let you know if everything is all lined up!

  6. #5
    Baby Twin
    Join Date
    Mar 2012
    Location
    stockport, cheshire
    Posts
    26
    HI, i have reassembled brake discs on front wheel and put the wheel back on bike, discs fit fine and wheel is all aligned and running true, but when i put calipers back on and brake disc is still of set with caliper. Brake discs are fixed and calipers are fixed and i don't know what the hell is going on! I took the wheel of and brake discs to make sure there was no excessive build up of powder coat since i had the wheels coated a couple of years ago, i know its sounds stupid but i cannot figure out what is wrong and if anything is out and where the problem stems! If i could figure out how to put pictures on thread it would probably be a little clearer.

  7. #6
    Baby Twin
    Join Date
    Mar 2012
    Location
    stockport, cheshire
    Posts
    26
    Hi, Can anybody explain how i get pictures onto the thread, i have tried and all i get is a message instead of pictures.Brake calipers and discs-img-7749.jpg Thanks

  8. #7
    Baby Twin
    Join Date
    Mar 2012
    Location
    stockport, cheshire
    Posts
    26
    My bad it worked yeah! Brake calipers and discs-img-7750.jpg right and left calipers with disc of set, are they suppose to be like this?

  9. #8
    Adrenaline Junky CrashB's Avatar
    Join Date
    Mar 2013
    Location
    South East Wales
    Posts
    2,682
    Tried reversing the spindle?


    '97 TL1000S Streetfighter 'Evil Twin' - Full colour wiring diagrams - click here for UK TLS - click here for US TLS - click here for UK TLR - click here for US TLR

  10. #9
    Baby Twin
    Join Date
    Mar 2012
    Location
    stockport, cheshire
    Posts
    26
    Quote Originally Posted by CrashB View Post
    Tried reversing the spindle?
    Hi, no I haven’t , I will try anything, so reverse the axle ? I will try weekend , I will keep everyone updated, cheers

  11. #10
    Adrenaline Junky CrashB's Avatar
    Join Date
    Mar 2013
    Location
    South East Wales
    Posts
    2,682
    Just a thought. I've never used TL forks so I could be barking up the wrong tree completely, but the photos suggest that the wheel itself is off center, and this is the only thing I can think of that would explain it.


    '97 TL1000S Streetfighter 'Evil Twin' - Full colour wiring diagrams - click here for UK TLS - click here for US TLS - click here for UK TLR - click here for US TLR

Page 1 of 4 1234 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •