Help wanted in Brighton UK
Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By CrashB

Thread: Help wanted in Brighton UK

  1. #1
    Silver Subscriber tommotbird's Avatar
    Join Date
    Oct 2011
    Location
    Brighton, UK
    Posts
    303

    Help wanted in Brighton UK

    Hello All
    About 3 years ago I stripped my TLS down to fit a new fuel pump and front plug and thats where it stopped.
    I now can't remember where everything goes for reassembly.
    Anyone available in Brighton area to give me a hand?
    Message me or call 07967 034410
    Tommotbird.

  2. #2
    One Liter Duc Eater geofftl1000r's Avatar
    Join Date
    May 2008
    Location
    Salfords near Redhill
    Posts
    846
    I often use the micro fiche pictures to get an idea where everything goes. RonAyres has some good pictures.
    I might be able to come around this weekend if no-one local can help.

    http://www.ronayers.com/oemparts/a/s...pump-fuel-pump

    Did you get a new seal? I here these can be a right pain.... at least on the R
    " I started out with nuthin' and I still got most of it left"

  3. #3
    Silver Subscriber tommotbird's Avatar
    Join Date
    Oct 2011
    Location
    Brighton, UK
    Posts
    303
    Hi Geoff
    I got a new fuel pump gasket/ seal and fitted the fuel pump, however it still leaked even after torquing the nuts to the right pressure.
    I think that I am going to use gasket sealant and then bolt it in.
    You can come round this weekend if you are free, it will help too spur me on and put me in the right direction. It's been off the road for too long.
    Regards
    Geoff T

  4. Remove Advertisements
    TLZone.net
    Advertisements
     

  5. #4
    Silver Subscriber tommotbird's Avatar
    Join Date
    Oct 2011
    Location
    Brighton, UK
    Posts
    303
    Anyone?

  6. #5
    Silver Subscriber tommotbird's Avatar
    Join Date
    Oct 2011
    Location
    Brighton, UK
    Posts
    303
    Hi All

    I replaced the fuel pump yesterday with one that tested good. With gas in the tank it primed OK but now when I try to fire it up there is no noise of the pump priming. Looks like i now have to buy another pump? Had to use gasket compound to seal the pump as i couldn't get it to seal without it. Is there something that causes the pump to dysfunction?
    Any ideas as this is becoming a pain!

  7. #6
    Adrenaline Junky CrashB's Avatar
    Join Date
    Mar 2013
    Location
    South West UK
    Posts
    1,924
    If you can wait till later I will post the fuel system diagrams so you will know where and how to test it all. Unfortunately its on the home computer!


    '97 TL1000S Streetfighter 'Evil Twin' - click here for full colour UK TLS wiring diagram - click here for full colour US TLS wiring diagram - full colour TLR wiring diagrams coming soon


  8. #7
    Adrenaline Junky CrashB's Avatar
    Join Date
    Mar 2013
    Location
    South West UK
    Posts
    1,924


    Right...

    Step 1: check that the pump is working by applying a direct line from the battery +ve to the red/white wire leading to the fuel pump. For this I have a few lengths of wire with crocodile clips at each end. If that whirrs, then your pump is fine.
    Step 2: using a multimeter check that the red/white at the loom side of the fuel pump is getting power on start up.
    Step 3: Check at the orange/blue wire into the fuel pump relay is getting power on start up.
    Step 4: Check that the light brown wire into the fusebox for fuse 5 is getting power.

    Now report back.

    It might also be worth checking that: The bike isnt in gear. The side stand isnt down. The killswitch is set to 'run'.
    The Rat likes this.


    '97 TL1000S Streetfighter 'Evil Twin' - click here for full colour UK TLS wiring diagram - click here for full colour US TLS wiring diagram - full colour TLR wiring diagrams coming soon


  9. #8
    GP Champ rxf610's Avatar
    Join Date
    Oct 2013
    Location
    Georgia, US
    Posts
    1,293
    I can work for $0 an hour...

    Or shekels per millimeter, or whatever the imperial wage rate is...

    All you have to do is fly me over and pick me up from the airport! But I guarantee we get that thing running!
    ... listen to Six5 ...

  10. #9
    GP Champ rxf610's Avatar
    Join Date
    Oct 2013
    Location
    Georgia, US
    Posts
    1,293
    Quote Originally Posted by CrashB View Post
    crocodile clips


    I call them alligator clips...

    And you have neither in the UK...

    I guess in zoos. Or here...

    http://www.express.co.uk/news/uk/684...lligator-photo
    ... listen to Six5 ...

  11. #10
    Adrenaline Junky CrashB's Avatar
    Join Date
    Mar 2013
    Location
    South West UK
    Posts
    1,924
    Quote Originally Posted by rxf610 View Post
    And you have neither in the UK...
    I might live in the UK now, but I grew up in the southern hemisphere, which is where I learnt the term :rofl


    '97 TL1000S Streetfighter 'Evil Twin' - click here for full colour UK TLS wiring diagram - click here for full colour US TLS wiring diagram - full colour TLR wiring diagrams coming soon


Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •